PRÉSENTATION

Bauh, pour gérer vos applications Linux. Si vous installez plein de logiciels sur votre Linux et que vous commencez à avoir du mal à tout suivre, j’ai une solution beaucoup plus sympa qu’un simple listing interminable dans le terminal.

Cette solution, c’est Bauh (prononcez Ba-Ou) anciennement connu sous le nom fpakman qui n’est ni plus ni moins qu’une interface pour gérer vos applications Linux, que vous les ayez installés à l’aide d’AppImage, de Snap, Flatpak, ou encore des dépôts Arch Linux / AUR.

Il y a aussi une suggestion d’applications comme GameHub, Netflix, Disney+, Gmail, Spotify, Outlook, etc 27 apps au total.

AVANTAGES

  • installation et désinstallation
  • mises à jour des flatpak et autres
  • rollback pris en charge
  • proposition d’applications web (netflix, Disney plus) et autre flatpak

INCONVÉNIENTS

  • néant

INSTALLATION

UBUNTU / MINT / ZORIN

DÉPENDANCE :

 sudo apt-get install python3 python3-pip python3-yaml python3-dateutil python3-pyqt5 python3-packaging python3-requests

INSTALLATION PIP3 :

 sudo pip3 install bauh

MISE À JOUR :

 sudo pip3 install bauh –upgrade

DÉSINSTALLATION :

 bauh –reset # removes cache and configurations files from HOME
sudo pip3 uninstall bauh

LANCEMENT :

 bauh

TEST

Utilisation de la mémoire : 132 Mo


LIENS

  • Télécharger l’AppImage Releases : Lien
  • Source GitHub : Lien
  • Source @Korben : Lien

VIDÉOS

  • Source : néant

Cet article a 2 commentaires

  1. Mise à jour 0.10.4 : https://github.com/vinifmor/bauh/releases/tag/0.10.4

    change log : (traduction a approximative)
    Améliorations

    Cambre
    – remplacé certains appels système par des appels Python

    Correctifs

    AppImage
    – certaines entrées du bureau ne s’affichent pas dans le menu de l’environnement de bureau (nécessite la réinstallation de l’AppImage) #287
    Cambre
    – ne pas détecter certains remplacements de packages lors de la mise à niveau en raison d’informations de conflit ayant des opérateurs logiques (par exemple : at-spi2-core: 2.44.1 -> 2.46.0devrait remplacer l’installé at-spi2-atk: 2.38)
    – ne pas tenir compte de certaines expressions de conflit lors de la récupération des exigences de mise à niveau ( cela pourrait entraîner une panne du système en fonction du conflit )
    DebianName
    – ne pas gérer correctement les paquets dont les noms se terminent par :i386 #298
    Emballage
    – AppImage : télécharger le numéro de certificat n ° 280
    interface graphique
    – la taille du panneau d’initialisation n’est pas basée sur la taille actuelle du périphérique d’affichage
    – panneau de gestion :
    – pas pleinement maximisé
    – ne pas maximiser en fonction de la taille actuelle du périphérique d’affichage (pour plusieurs configurations d’affichage)
    – ne respectant pas une largeur minimale/maximale basée sur la taille actuelle du périphérique d’affichage (pour une configuration à plusieurs écrans)
    – dialogues ne respectant pas la largeur actuelle du périphérique d’affichage
    – ne pas réajuster la taille après avoir maximisé/minimisé

    Localisation (i18n)

    – Italienne ( @albanobattistella , @ luca-digrazia )
    – Turc ( @agahemir )

Laisser un commentaire